cancel
Showing results for 
Search instead for 
Did you mean: 

Hopeless? Brand new wifi is slow and iPad won't connect

loughroad
Fledgling

Hi all, I just got Three home broadband yesterday morning, router NR5103EV2, and it's been nothing but trouble. Am I missing something?

1. Slow speeds - my ancient ADSL reliably gets 33-37mps, but on Three I'm getting 10-35 mps (15 at the moment). The router is on the windowsill. To be fair, it's a 5G hub and I'm just outside the 5G coverage map (a few houses down on my street are inside the 5G range), but I was told the router would automatically switch to 4G, and I thought for sure 4G would still be faster than this since the coverage map says 4G indoor is "excellent" here.

2. I have an iPad Air 2 which sees the network but says "incorrect password" and refuses to connect. I spent an hour with Three tech support yesterday and they said it's an issue with the iPad, but Apple says it's a router issue. The iPad connects to every other wifi, just not this one. I've tried: hard restart on iPad, updated iPad ios, reset router, unplug router and plug back in, reset network settings on iPad - I'm out of ideas. 

Unfortunately the iPad is my only smart device, and since I can't connect it to the internet, I can't use the 5G hub app to see if I can play around with the router settings to try to fix it. Nor can I access any other apps, like my app-based bank account, so this a big problem.

I had such high hopes for Three, since I travel a lot in the UK and the mobility of the connection was going to be a game-changer... but this just won't work, unless I'm missing something really obvious?

6 REPLIES 6
sc1999
Local celebrity

I do not have 3 broadband but I am at the extreme edge of 5g coverage. I have to set my phone to ignore 5g as the phone defaults to the highest number, 5 not 4, rather than detecting the fastest speed. When in 5g mode the phone is to slow to open a web page. Is there a way to set your router to 4g only?

loughroad
Fledgling

Good question. I went to the web login address for the router and when I logged in I toggled "5Ghz wifi" off. It made no difference with the speed (if I toggle 5G on but 4G off, there's no internet at all). I can also see on the router admin page that it's getting 2 bars of LTE and 0 bars of 5G. If I'm reading this right it looks like it's using LTE access with a signal strength of -109 which, based on a google search, is pretty bad.

I also see that the firmware of the router is "V1.00(ACIR.0)b5" and there's no option to check for updates. Tech support told me yesterday that the router was updating itself from the factory, though, so presumably there is no need to update the firmware even if that was an option.

sc1999
Local celebrity

Does the router give 2.4 and 5GHz? My BT router puts out both but the 5GHz range is limited. Is the iPad set for both frequencies? If it is set to 5GHz only it will need to be in range of the router to connect.

Psmithson
Active

I have a similar problem with the same router. I can't connect any kindle e-readers to the 2.4 or 5Ghz WiFi network.

My workaround is to use the guest WiFi. Maybe that will work for you?

Though you can't do much about the slow speeds. If you are not getting 5G and your 4G connection is poor, then I guess you could try putting it near a window? My router gets a better signal with one particular side of the house. I mean, it gets a good mobile internet signal. The trouble is, it's then badly positioned for my laptop to get a good WiFi signal!

Spud
Involved

Try changing the security mode to "WPA/WPA2-PSK" and connecting the iPad to the 2.4GHz wireless.

WhiskyDiscovery
Fledgling

Did you find a fix for this? I've just switched to Three 5G from BT and everything else, but the ipads, connects without a problem. Neither of the iPads will connect in any setting, yet they work perfectly on the BT Router?