Our new roaming giveaway is live find out more here!
Give us your feedback about how easy you've found getting ready to roam on the above linked article, and you'll be in with the chance to win one of 10, 7 day Go Roam passes to use in Europe and Around the World destinations. Prize draw open till 01 May 2024
cancel
Showing results for 
Search instead for 
Did you mean: 

NR5103EV2 drop outs & performance issues

mtd7
Fledgling

I have a 5G broadband contract with a NR5103EV2; the router is experiencing frequent drop outs and performance issues. Most of these issues are usually resolved by rebooting the router on a daily basis, though sometimes the drop out can last 30-45 minutes in the worst cases.

During these drop outs, the router still has a blue internet light. In the System Info of the router admin page for Cellular WAN, LTE connection never drops below full bars, and 5G connection is always at 3 bars out of 5.

I am on V1.00(ACIR.0)C0 version of firmware.

I got chat support to investigate but in the end we concurred that this was probably an issue with the router and there was nothing they could do to help me.

These performance issues are not acceptable. I'm currently job hunting and I dread the idea of having one of these drops during an interview, especially if it lasts for 30 - 40 minutes, so I am having to use my (far more reliable, but metered and slower) GiffGaff 4G phone internet connection for these.

Can anyone suggest what steps I should take next? I suppose Three will want to replace my NR5103EV2, but a quick look at this forum suggests that this product is at the heart of the issue and simply replacing like-for-like is unlikely to resolve the issues, is it?

8 REPLIES 8
George5610
Fledgling

I have the same problem.
Same router and firmware version. I have tried multiple solutions but none of them have worked.
Spiting 2.4 and 5Ghz networks, turning off wifi and using an AP through ethernet. Changing the APN to three.co.uk. Disabling IPV6.
Annoyingly the 5G cell tower is 200m and visible from my window (where the router is sat) so I have a solid full bars of 5G.
After restarting the router I can get 700Mbps down and 70Mbps up, but that only lasts around 30 minutes before dropping to about 50-100 down and being really unstable.
It seems like this has been an issue from well before the end of last year and no solution has been provided.
I've run out of solutions to try and it seems like there is no engagement from the support team.

Sabcamoriginal
Fledgling

I'm having exactly the same problem.  Just signed a 24 month contract. I think I'm going to try and cancel it. I've heard sending back the kit can be a nightmare. Regarding them acknowledging receipt of the item once it has been returned etc

KateS
Community Support Team
Community Support Team

Hey @mtd7 @Sabcamoriginal @George5610,

I'm sorry to hear you've all been experiencing issues with drop-outs on the Home Broadband routers.

I'm keen to look into this, so I've dropped you all a PM requesting some further info to allow me to investigate further.

Thanks,
Kate

Zayn
Fledgling

Hi Kate, I am having the exact same issue of signal very frequently dropping. I also just recently renewed my contract and want to leave if this continues. Can you please help? 

JonathanB
Community Moderator
Community Moderator

Hi @Zayn,

I've sent you a PM to request some info to help us look into this.

To view your private messages on the community, click on your avatar image in the top right of any community page, then "Messages".

Thanks,
Jonathan



We'd like to hear your feedback! Let us know how easy you find it to get ready to Roam, and be in with a chance to win 7 days of free Roaming Passes – find out more here!


Hi Jonathan,

Is there any update on this thread? I have heard no response from Kate regarding this.

 

Thanks,

George 

JonathanB
Community Moderator
Community Moderator

Hi George,

Sorry for the delay, Kate popped you another PM earlier today. You should find some info on the next steps there.

To view your private messages on the community, click on your avatar image in the top right of any community page, then "Messages".

Thanks,
Jonathan



We'd like to hear your feedback! Let us know how easy you find it to get ready to Roam, and be in with a chance to win 7 days of free Roaming Passes – find out more here!


Psmithson
Active

I had similar issues and gave up. I bought a second hand Nokia Fastmile router on eBay and that works a lot better (even though it's designed for another ISP)