Showing results for 
Search instead for 
Did you mean: 

Register button not working


I've tried multiple times over the past few weeks to re-register my account so that I can access my account details. Every time I do this I have an issue at the exact same point; after following the steps of registering, it tells me to complete the hCAPTCHA step. After completing this absolutely nothing happens. I do not recieve an e-mail validation link or anything. The Register button is completely dysfunctional.

I have tried on multiple different browsers (Chrome, Firefox, Edge, Safari etc), different devices (my3 app on mobile, web browser on PC, Laptop and iPad), and have made sure all extensions have been disabled. This has made no difference and the same issue occurs with them all.

I've spoken with customer support multiple times and the first time they sent me a verification e-mail which lo and behold, sent me straight back to the register page where the same issue occurred. The last time I spoke with support they said it was a website issue and that I would have to physically go into a three store to get it fixed.

I've looked through the forums and have seen this being an issue since early last year. I do not have the ability to visit a three store currently due to work, so how on earth am I able to access my own account when the website is apparently the issue and customer support are unable to do anything about it?

Community Moderator
Community Moderator

Hi @arejay,

This sounds really frustrating. Can you walk us through the errors you're encountering? You can add screenshots to your community posts too (make sure to block out personal details like phone numbers).


Mod tip! The author of a post can hit 'Accept as Solution', to highlight a reply that helped solved their query.