Our new roaming giveaway is live find out more here!
Give us your feedback about how easy you've found getting ready to roam on the above linked article, and you'll be in with the chance to win one of 10, 7 day Go Roam passes to use in Europe and Around the World destinations. Prize draw open till 01 May 2024
cancel
Showing results for 
Search instead for 
Did you mean: 

poor wireless broadband in Northampton NN3 area

tonyturtel
Active

Hi all is anyone else still experiencing very poor wireless broad band in Northampton I have been having this issue for over 2 weeks and have been in contact with help desk and virtual assistant at least 4 times and just keep getting told that their best engineers are on it by people who sounds like they are in India and don't understand English. I have been with 3 mobile and internet for many years and feel very let down by this company and have decided I have no other choice than to leave the network and seek more reliable internet in the future.

Best solution
Best solution
meatpaste
Regular

yes it is still broken, i've had support telling me that i have poor coverage, while in the same chat confirming via router settings that i have excellent signal, so this must be something wrong with the mast/infrastructure. speed test shows normal upload speed all along. they refuse to escalate the issue beyond the robotic scripted answers. sounds like they are trying to hide something maybe as the status checker reports no issues as well! i've resolved it temporarily by getting a Lyca sim card, this might end up being my long-term solution 🙂

View solution in conversation

12 REPLIES 12
MZone
Rising star

Put your postcode in the Network Status checker to see if any issues/updates in your area. Also try rebooting your router.

tonyturtel
Active

done both of them many times doesn't work and just get this message for 2 weeks and 1 new modem latter 

 
We're working on fixing an issue in this area at the moment. We're sorry for any disruption this may be causing.We hope to have things fixed as soon as possible and will add any updates here.
meatpaste
Regular

The status checker is giving incorrect information, the support person told me..

"There is no maintenance going on but just a network limitation and im not getting any fixed date as to when it will be sorted. So you can either test it for few days if you want, or if you want then we can go ahead and explore cancellation options if you want, as the network is limited in the area."

This is despite being a customer for over 2 years and getting > 400Mbps and full signal strenght throughout that time. An honest answer would be much appreciated!

MZone
Rising star

It’s just a matter of waiting until it’s fixed then unfortunately. I would however try and seek some line rental reimbursement/compensation for the poor quality of service you are experiencing. Call 333 or go on live chat and raise a complaint. 

SlyReg
Regular

Hi

I had tied my router to 4G for over a week as the 5G in NN4 had dropped to unusable speeds, kept trying 5G and yesterday it came back and is currently looking OK.

Helpdesk were completely useless, they had less idea than I did as to what was going on, blamed the Sim and the router.

Hopefully the 5G is back to stay now

Reg

tonyturtel
Active

I wish mine was back i'm in NN3 area and my connection is so slow it is 0.5 megabits per second and has been like this over the last 2 weeks. Help desk absolutely useless they sent me new router and sim card and that made no difference told me to move it around the house and that made no difference and then claimed their best engineers are on it 

ctedder
Fledgling

nn9 isn't working ether and has been like it for over 2 weeks  Help desk absolutely useless  i have returned my router and have been told as soon as they receive it they will close the account. worrying i sent it in the returns bag last week and the account is still open just spent over 2 hours on the phone to tell me that nobody was available to tell me what was going on ? I'm verry disappointed in the verry poor service that 3 have given out  

Best solution
meatpaste
Regular

yes it is still broken, i've had support telling me that i have poor coverage, while in the same chat confirming via router settings that i have excellent signal, so this must be something wrong with the mast/infrastructure. speed test shows normal upload speed all along. they refuse to escalate the issue beyond the robotic scripted answers. sounds like they are trying to hide something maybe as the status checker reports no issues as well! i've resolved it temporarily by getting a Lyca sim card, this might end up being my long-term solution 🙂

I did the same with an EE card works perfectly so has to be something to do with the Three network but they won't own up to it as they would have to pay compensation