Showing results for 
Search instead for 
Did you mean: 

Apple Watch Series 9 unable to pair with Three


I purchased a new Apple Watch Series 9 yesterday. I was able to pair it to my iPhone XS but like thousands of other people in this forum, I’m unable to pair the watch with Three when attempting to activate the mobile service feature. 

This is my first Apple Watch and it’s a shame Three has an outdated network that doesn’t support Apple Watch Cellular functionalities. This was one of the main reason for spending extra money on purchasing the watch (to take calls and send / receive texts). 

I have tried everything from what I’ve seen on these forums like resetting the watch clearing safari browser history, turning both watch and phone on and off, changing My3 Password, putting the password first before the email, three customer service were useless. NOTHING is working. 

I keep receiving the “one of the fields is missing” error like everyone else is. 

Is there anything else I can try? If not then I’m going to switch to another company. 



I am having the extact same issue trying to pair to my iPhone 15. It is Crap but also what I have come to expect......


Did you manage to get it sorted. I’ve had the same issue for about two weeks trying to connect my series 9 with 15 pro max same message as everyone else 


1000's is a tad of an exaggeration but I get your point.


Interesting how you’ve picked up on that one statement and used it to slight their complaint.  What the OP is getting at here, quite rightly frustrated is that It’s clear to see that this issue is a very common complaint clearly evident on this forum.  One person with a problem is one person too many. 


Yes I have exactly the same issue. I tried everything even phoning apple, un pairing the watch, deleting the app, reinstalling the app, re pairing the watch.  No change.  Apple said they believe it is an error with the link to Three.

Went into store and was told this was a known issue and to phone customer services.  When I eventually got through to technical support I was told it was not a known issue and that it must be my fault.

He told me to do the same as Apple said and that he would phone me back. He didn’t of course.

I went back into store and the manager said it was definitely a known issue and has been known about for some 5 months!


It is also not possible I was told, for anyone other than me to add the service plan, except of course I can’t either.


Total sham as the Three website still totes the ease at which thus can be done.


I am within my 14 days and intend to return the iPhone as someone is being less than truthful at Three.


After 10 days of lots of calls to Three, numerous resets of my new Apple Watch (and new iPhone) I managed to get it working myself.

The key for me was to reset my Three password to one that did not include characters. I don’t know why this worked (the Apple Watch I replaced was only set up for SmartWatch pairing 12 months ago and the password was fine). Anyway,

  • I changed the Three password to one with numbers and letters only.
  • I cleared the Safari history on my iPhone.
  • Set my display auto-lock to ‘never’ (temporarily of course).
  • I unpaired and paired the watch again (whilst on charge).
  • I opted to keep the smartwatch pairing plan (sometimes it asks when unpairing/pairing - other times it does not???).
  • I made sure the Watch and iPhone were on the latest OS and it all worked! 

One point to note, in the watch app under Mobile Service/ Mobile Plan it was stuck on ‘activating’ for at least 25 mins. I stayed on this screen for the duration. Eventually the message changed from ‘Activating’ to ‘Three’ and the Watch is now paired.

The Watch App still had a red ‘1’ on the message ‘finishing set up this Apple Watch’ or whatever it says. I selected it and closed the App a few times - it would not go, eventually it did. Reminder, set display back to auto-lock. 

Hope this helps someone. 


So I’m not the only one who has the issue of pairing my Apple Watch mobile data plan to my iPhone this has been an issue for about week now when I first got my Apple Watch customer service useless live chat useless I’ve tried everything in this forum and still not working. 


I have this problem with my Apple Watch Ultra 2. I have had this working before I upgraded from an Apple Watch 7. I am also waiting for a solution. Its very frustrating, this should just work.

Community Moderator
Community Moderator

Hi @Grizzly,

I'm sorry to hear you're also having issues pairing is it the "One of the fields is missing" error, or if not can you let us know what you're seeing when you try to pair?

@mysite123 replied on this thread with a few steps to try have you been able to test these?

Let me know on the above and if you're still facing any errors I'll direct you to some more help.


Mod tip! The author of a post can hit 'Accept as Solution', to highlight a reply that helped solved their query.