Our new roaming giveaway is live find out more here!
Give us your feedback about how easy you've found getting ready to roam on the above linked article, and you'll be in with the chance to win one of 10, 7 day Go Roam passes to use in Europe and Around the World destinations. Prize draw open till 01 May 2024
cancel
Showing results for 
Search instead for 
Did you mean: 

Zyxel NR5103E IP Passthrough

aflatbroke
Regular

Hello! 

I ordered the Three 5G Hub Zyxel NR5103E, I have intermittent 5G, varying from as low as 24mbps to 580mbps. My home network is a Unifi USG gateway followed by Access Points.

I am using the NR5103E in (IP Passthrough) Bridge Mode via Lan ethernet to my Unifi USG. Even though I have put the NR5103E in IP Passthrough and Allowed the USG to do the Routing etc.

The problem is the NR5103E is not passing its WAN IP to the USG. Instead it is passing one DHCP IP address. Anyone know another setting to get the WAN IP to the USG?   

 

 

  • 5G
12 REPLIES 12
PeteG
Community Support Team
Community Support Team

Hello there. 

Welcome to the Three Community. 

Oh that's an interesting question. I'm not sure what features are available on the latest Zyxel software, but I don't think it has bridge mode on it. In any case, bridge mode is normally only needed for wireless networks. If you're connecting to the Zyxel through ethernet, it should be able to do what you want, and bypass it's wireless features. 

I'm not familiar with the system you are using, but if you've set it to bridge mode, it might be performing it's own NAT. It might be worth connecting it in standard routing mode to see if this produces the results you desire. 

Pete. 

crypt0ninja
Established

Hi Pete,

IP Passthrough is supposed to be the same as Bridge Mode AFAIK (correct me if I'm wrong), and when enabled the NR5103E should essentially just act as a modem and nothing else, all DHCP, Routing, QOS etc should then be handled by the passthrough device connected to the NR5103E via ethernet e.g. Aftermarket Router/Mesh system

Without bridge mode/IP passthrough for these types of setups (which are common tbf) you potentially run into double NAT issues which can be problematic.

I did quickly try IP Passthrough on the NR5103E recently with a TP-Link Deco P9 set and had the same problem as @aflatbroke where the Deco was not being passed the WAN IP it was still being given an internal address so it may possibly be a bug, however I didn't thoroughly test and I cant do any further tests as I just sent the Deco P9 kit back as the performance was awful lol

As IP Passthrough didn't work for me when I was running the Deco's I just set the Deco's to run in AP mode instead of Router mode, so that the NR5103E managed all DHCP, NAT, Routing etc and the Deco's became simple access points (this method also avoids double NAT but when you spend good money on a router you ideally want it to be managing everything, hence IP Passthrough/Bridge Mode).

I'll try do some more testing when I find a better powerline mesh network setup for my home.

aflatbroke
Regular

Thanks for your input cryt0ninjaI think to have the WAN IP pass through the NR5103E it doesn't feel like a software bug, but IP Passthrough should do just that! I wonder if it's something to do with it being a mobile sim. My current set up is a hard wired copper to fibre cabinet down the road through a Draytek 130 modem in bridge mode, through Cat6 to a Unifi USG with access points through Unifi AC Pro's. I also have Unifi Nano Beams sending my internet to Neighbour 100m down the road. I get around 50mbps up and 18 down. The system works floorless. But with 5G through the NR5103E giving me between 80-700mbps but latency is terrible. The idea is with IP Passthrough it would be a great solution to have that speed. I too will continue to experiment and post if I find a solution.          

floored
Fledgling

Hey @aflatbroke did you end up finding any solution to this? 

aflatbroke
Regular

Hi Floored, sorry I have not found a solution. It seems this is a common issue with mobile broadband. I now use the 5G NR5103E as a standby as I said latency is terrible and speeds are to erratic. So it sits there costing me £20/month. If you have better luck please post here. Thank you.    

davidraw
Fledgling

Hi,

I just set my NR5103E in IP PASSTHROUGH mode connect by ethernet to a tp-link ER605 router and it worked 1st time.

My ER605 has a WAN address in the public internet range rather than the locat 192.168.1.1/24 range it had before.

It doesn't seem to have significantly changed speed or pings, but it's nice not to have a double NAT situation anymore.

davidraw
Fledgling

After a day or two I hit a problem - my router couldn't get the WAN ip address from the NR5103E... so maybe the required functionality is not quite there yet.

Having tried everything I could find in the web interface, I reset the router to factory and I'm double-NATing again 😥

Waggers
Regular

Can I ask where you found the IP Passthrough settings?

I've just received my NRT5103E running firmware V1.00(ACBJ.0)b14 and I can't see any setting for IP Passthrough.

Waggers
Regular

Ah, found it!  Under broadband settings.